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Accessibility Features and Options Built Into the 5 Most Popular Web Browsers 

Basic Information Internet Explorer Mozilla Firefox Opera Apple Safari Google Chrome 

Website 

http://www.microsoft.co
m/windows/internet-
explorer/download-
ie.aspx  

http://www.mozilla.com
/en-US/firefox/  

http://www.opera.com/ 
http://www.apple.com
/safari/download/  

http://www.google.com/
chrome/  

Accessibility 
Information 

http://www.microsoft.co
m/enable/products/ie7/
default.aspx  

http://support.mozilla.c
om/en-
US/kb/Accessibility  

http://www.opera.com/
products/desktop/acce
ss/index.dml  

http://www.apple.com/a
ccessibility/  

http://www.google.com/
support/chrome/bin/an
swer.py?answer=9683
1&topic=14661 

Assistive Technology 
Product Compatibility 

http://www.microsoft.co
m/enable/at/search.asp
x  

http://support.mozilla.c
om/en-
US/kb/Assistive+techn
ology+compatibility  

No information 
available. 

http://www.apple.com/a
ccessibility/resources/  

No information 
available. 

Current Version 7.0 3.0.3 9.6 3 1.0 

For Use With Microsoft Windows 
Microsoft Windows; 
Mac OSX; Linux 

Microsoft Windows 
Microsoft Windows; 
Mac OS 

Microsoft Windows 
Vista/XP SP2 

Feature or Option Internet Explorer Mozilla Firefox Opera Apple Safari Google Chrome 

Built-in Text Reading 
(screen reading 
functions) 

Microsoft has a search 
tool which will 
recommend different 
types of solutions but 
does not have a screen 
reader built into IE7. 
For more information, 
visit 
http://www.microsoft.co
m/enable/at/search.asp
x.  

No information 
available. 

No information 
available. 

Apple has built many 
accessibility solutions 
directly into its 
products as standard 
features. VoiceOver, 
screen reading 
technology that’s part 
of Mac OS X, provides 
voice description and 
offers plug-and-play 
support for Braille 
displays. 

No information 
available. 

Page Zoom In or 
Zoom Out 

 Click the 
Magnifying glass 
icon at the bottom 
right corner of the 
Internet Explorer 
window. Or, select 
the arrow to open 
the list of options 
and select one. 

You can zoom in and 
out of pages including 
images, in the View > 
Zoom menu, or with 
the following keyboard 
shortcuts:  

 Press CtrlCmd++ 
to display the web 
page one size 

Zoom the contents of a 
document (text and 
images) from 20%-
1000% either from the 
drop-down zoom box 
at the top of the 
browser or by simply 
pressing + to zoom in 
or - to zoom out. 

No information 
available. 

No information 
available. 
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 Press CTRL + 
PLUS SIGN (+) to 
zoom in, or CTRL 
+ HYPHEN (-) to 
zoom out. 

larger.  

 Press CtrlCmd+- to 
display the web 
page one size 
smaller.  

 Press CtrlCmd+0 
to display the web 
page at its normal 
size. 

Increase or Decrease 
Text Size 
 
**Note that some web 
pages may display 
incorrectly if you 
increase or decrease 
the text size 

To change text size, 
open Internet Explorer 
7, select the “Page” 
menu, then “Text Size” 
then choose between: 
largest, larger, 
medium, smaller, and 
smallest text sizes. 

You can temporarily 
change the size of text 
on any web page in the 
View > Zoom menu, 
with Zoom > Text Only 
enabled. The following 
keyboard shortcuts 
control text size: 

 Press CtrlCmd++ 
to increase the text 
size.  

 Press CtrlCmd+- to 
decrease the text 
size.  

 Press CtrlCmd+0 
to reset the text 
size to the web 
page's default size. 

Zoom the contents of a 
document (text and 
images) from 20%-
1000% either from the 
drop-down zoom box 
at the top of the 
browser or by simply 
pressing + to zoom in 
or - to zoom out. 

Maybe the text field 
you’re typing in is a bit 
too small to read. Or 
maybe you just have a 
lot to say. Either way, 
Safari lets you resize 
text fields on any 
website, just by 
grabbing the corner of 
the field. Resize a field 
and the web page 
reflows to make room. 
 
To quickly change font 
size: 
 

 Select the text you 
want to edit.  

 To make the text 
larger, press the 
Command and “+” 
keys at the same 
time.  

 To make the text 
smaller, press the 
Command and “-” 
keys at the same 
time. 

To change text size in 
Google Chrome: 
 

 Ctrl++ to make text 
larger 

 

 Ctrl+- to make text 
smaller 

 

 Ctrl+0 to return to 
normal text size 

Override/Change 
Color Scheme  
 
** Many web pages set 
their own colors, so 
your choices will have 

In Internet Explorer 7, 
choose “Tools” then 
“Internet Options”. On 
the “General” tab, 
select “Colors”. 
Remove the check 

 You can set your 
default colors by 
going to Tools > 
Options > Edit > 
Preferences> 
Firefox > 

To change the color of 
text and links:  
 

 Go to File > 
Preferences > 
Fonts and colors. 

No information 
available. 

No information 
available. 
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no effect. mark next to “Use 
windows Colors” then 
choose your own 
colors, background and 
link colors by choosing 
from the available 
colors. 

Preferences, 
selecting the 
Content panel, and 
clicking the Colors 
button in the Fonts 
& Colors section. 
You can set default 
text and 
background colors, 
as well as default 
colors for visited 
and unvisited 
hyperlinks. To 
override the colors 
defined by web 
pages, uncheck 
“Allow pages to 
choose their own 
colors.” 

Change the fonts 
and colors of the 
text and links, 
background color, 
and minimum text 
size to a style that 
better suits you. 

Using High Contrast 
No information 
available. 

Firefox automatically 
detects if you are using 
a High Contrast theme 
and displays 
everything in your high 
contrast color scheme. 
This overrides all other 
browser or web page 
settings, and it affects 
the Firefox interface 
itself (all menus, 
windows, and dialog 
boxes) and the content 
of any web page you 
visit.  

 To use a High 
Contrast theme, go 
to Start Menu > 
Control Panel > 
Accessibility 
Options > Display 
and check the 
“Use High Contrast 
option” preference. 

No information 
available. 

No information 
available. 

No information 
available. 
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Turning Off Java 
Applets, GIF 
Animations, Video 
Displays 

Open Internet Explorer 
7, click on “Tools” then 
“Internet Options”. 
Under “Advanced”, 
select the appropriate 
JavaScript options of 
your choosing. 

Some web pages 
provide a rich 
interactive experience 
with Java™ applets. 
However, some users 
that rely on keyboard 
navigation may 
experience problems 
with some Java applets 
that automatically set 
focus and do not 
provide a way to break 
out of the applet and 
navigate to the rest of 
the web page.  

 You can disable 
Java by going to 
Tools > Options > 
Edit > Preferences 
> Firefox > 
Preferences, 
selecting the 
Content and 
unchecking the 
“Enable Java 
option” preference. 

Opera lets you disable 
GIF animations, video 
displays, and Java 
plug-ins that can be 
obtrusive if you have 
difficulty changing 
focus or experience 
eye strain.  
 

 Press G to toggle 
images on/off on a 
page. This allows 
you to only view 
text and the page 
will load much 
faster.  

 To disable GIF 
animations go to 
File > Preferences 
> Multimedia and 
uncheck the 
"Enable GIF 
animation" box in 
the images 
section. 

 To disable video 
displays, Java, and 
plug-ins go to File 
> Preferences > 
Multimedia, then to 
the "Media types" 
section, and 
uncheck the 
actions you want to 
disable. 

Enable Java: The 
animation, interactive 
features, timers, and 
other enhancements 
on webpages are 
sometimes provided by 
a type of software 
program known as 
Java. To block Java, 
deselect this checkbox.  
 
Enable JavaScript: 
JavaScript is a 
software technology 
needed on most 
webpages for buttons, 
online forms, and other 
content to work 
properly. To block 
JavaScript, deselect 
this checkbox. 
Important: Disabling 
JavaScript will cause 
some sites to not work 
properly. 

No information 
available. 

Restricting 
JavaScript Behavior 
 
** Some web pages 
rely on JavaScript and 
may not work properly 
if JavaScript is 
disabled. 

Open Internet Explorer 
7, click on “Tools” then 
“Internet Options”. 
Under “Advanced”, 
select the appropriate 
JavaScript options of 
your choosing. 

 You can turn off 
JavaScript entirely 
by going to Tools > 
Options > Edit > 
Preferences > 
Firefox > 
Preferences, then 
selecting the 

No information 
available. 

Enable Java: The 
animation, interactive 
features, timers, and 
other enhancements 
on webpages are 
sometimes provided by 
a type of software 
program known as 

No information 
available. 
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Content panel, and 
unchecking 
“Enable 
JavaScript”.  

If you do not wish to 
disable JavaScript 
entirely, there are also 
a number of advanced 
JavaScript settings to 
restrict the behavior of 
scripts. 

 Immediately after 
the Enable 
JavaScript 
checkbox, click the 
“Advanced” button 
to open the 
Advanced 
JavaScript Settings 
window. You can 
control whether 
scripts are allowed 
to move or resize 
existing windows, 
raise or lower 
windows, disable 
or replace context 
menus, hide the 
status bar, or 
change status bar 
text. 

Java. To block Java, 
deselect this checkbox.  
 
Enable JavaScript: 
JavaScript is a 
software technology 
needed on most 
webpages for buttons, 
online forms, and other 
content to work 
properly. To block 
JavaScript, deselect 
this checkbox. 
Important: Disabling 
JavaScript will cause 
some sites to not work 
properly. 

Search for Text When 
I Start Typing 

No information 
available. 

Search for text when I 
start typing allows you 
to quickly navigate to 
text or hyperlinks in a 
web page. 
This feature has two 
modes.  

 Press / and start 
typing to search all 
text on the current 
page, or press ' 
before your string 

No information 
available. 

No information 
available. 

In Google Chrome, you 
can get anywhere on 
the Web with one box. 
The address bar that 
sits at the top of the 
normal Google Chrome 
window simplifies your 
Internet experience by 
doubling as a search 
box. You can also use 
it to bookmark 
websites and stay 
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to search 
hyperlinks only.  

Firefox will highlight 
matching text or 
hyperlinks as you type. 

aware about the 
security of a website. 

Implement Your Own 
Style Sheet 

 Start > IE7 > Tools 
> Internet Options 
> On the general 
tab, select the 
Accessibility 
button. Under User 
style sheet, select 
"Format 
documents using 
my style sheet." 
Type in the name 
of your style sheet 
or navigate to it by 
selecting the 
browse button. 

 To learn how to get 
your own custom 
style sheet, visit 
http://www.microso
ft.com/enable/traini
ng/ie5/css.aspx.  

No information 
available. 

 You can specify 
your own style 
sheet and disable 
the document's 
style sheet, which 
will let you view the 
page with the 
colors and fonts 
you prefer. In File 
> Preferences > 
Page style, you 
can select that 
Opera displays the 
pages with the 
colors, fonts, and 
link style that you 
choose. Select "My 
style sheet", "My 
fonts", etc., and 
insert the file of the 
style sheet you 
have authored 
and/or customized.  

 You can switch 
between the "User 
mode" or "Author 
mode" style sheet 
by pressing Ctrl+G, 
or by clicking the 
User mode/author 
mode icon you find 
on each page. The 
"User mode" style 
sheet lets you 
customize the 
color of the font 
and the 
background, as 

To set options for 
webpage fonts: 

 Choose Edit > 
Preferences.  

 Click Appearance, 
and then set font, 
images, and 
encoding options.  

 Click Advanced to 
set font size and 
style sheet 
options. 

No information 
available. 

http://www.microsoft.com/enable/training/ie5/css.aspx
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well as the text 
size. For example, 
if black text on a 
white background 
strains your 
eyesight, you can 
change the 
background to 
black with a green 
font for easier 
reading. The 
"Author mode" 
displays the Web 
pages as the Web 
designer or author 
intends it to be 
seen. 

Sound Alerts/Play 
Sounds 

Open Internet Explorer 
7, click on “Tools” then 
“Internet Options”. 
Under “Multimedia”, 
select “Play sounds in 
webpages”. 

No information 
available. 

Opera lets users 
implement sounds for 
several actions 
performed while 
surfing. Any sound can 
be installed for various 
movements, such as 
Opera start-up and 
exit, page loaded, 
transfer done, failure, 
instant message 
received, and follow 
link.  

 Go to File > 
Preferences > 
Sounds and 
choose a sound 
file for each event. 

No information 
available. 

No information 
available. 

Auto 
Completion/Auto Fill 

Open Internet Explorer 
7, click on “Tools” then 
“Internet Options”. 
Under “Browsing”, 
select “Use inline auto 
complete”. 

No information 
available. 

In the preferences 
menu, you can enter 
your personal 
information such as 
name, address, e-mail 
address, etc., which is 
commonly used to fill 
out forms on the Web. 

To enable AutoFill, 
choose Preferences 
from the Safari menu, 
click the AutoFill 
button, and select the 
"Using info from my 
Address Book card" 
checkbox. To make 

In Google Chrome, you 
can get anywhere on 
the Web with one box. 
The address bar that 
sits at the top of the 
normal Google Chrome 
window simplifies your 
Internet experience by 
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This information is only 
stored in your 
computer, and no one 
can access this 
confidential 
information. If you have 
a difficult time using 
the keyboard and 
typing, simply right-
click in the individual 
form fields and select 
"Insert" to access your 
personal information.  

 

 Go to File > 
Preferences > 
Personal 
information and fill 
in your information. 
This auto-
completion feature 
is also useful in the 
URL field. The 
auto-completion 
dropdown option in 
the URL field 
suggests 
previously visited 
pages so you don't 
have to retype the 
entire address. 
This accessibility 
feature lets you 
navigate the Web 
without depending 
too much on 
keyboard 
functionality. You 
can activate this by 
enabling it in the 
Preferences menu:  

 Go to File > 
Preferences > 

sure that your card is 
up to date, click the 
Edit button to open 
Address Book. 

doubling as a search 
box. You can also use 
it to bookmark 
websites and stay 
aware about the 
security of a website. 
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Accessibility. In the 
Keyboard section, 
check the box that 
reads "Enable 
auto-completion 
dropdown" 

Using Mouse 
Features, Gestures, 
Keyboard Shortcuts 

http://windowshelp.micr
osoft.com/Windows/en-
US/Help/fe192a3f-
1401-4233-919e-
cae97eca4c0c1033.ms
px 

http://support.mozilla.c
om/en-
US/kb/Mouse+shortcut
s  

http://www.opera.com/
products/desktop/mous
e/  

Open Safari. Click on 
“Help” then the 
“Search” tab. Type in 
“Shortcuts” then select 
“Safari Shortcuts”. A 
list will appear with 
various options. 

http://www.google.com/
support/chrome/bin/an
swer.py?answer=9574
3&ctx=sibling&topic=14
661 
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